Difference between revisions of "Windows installation/es"

From TidalCycles userbase
Jump to: navigation, search
(Created page with "= Probá tu instalación. =")
(Updating to match new version of source page)
 
(5 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 +
 +
= Easy install =
 +
 +
For an easy, automated install experience, see the [[Windows choco install]].
 +
 +
= Manual install =
 +
 +
If you prefer to install the different parts of a Tidal environment by hand, perhaps because you already have supercollider or haskell installed, then follow the below instructions.
 +
 +
<div class="mw-translate-fuzzy">
 
= Prerequisitos =
 
= Prerequisitos =
 +
</div>
  
 +
<div class="mw-translate-fuzzy">
 
== Recursos previos necesarios.==
 
== Recursos previos necesarios.==
 +
</div>
  
 
Antes de instalar Tidal, asegurate que los siguientes estén instalados.
 
Antes de instalar Tidal, asegurate que los siguientes estén instalados.
  
* Haskell Platform - '''the 'full' version is strongly recommended''', you can [https://www.haskell.org/platform/download/8.4.3/HaskellPlatform-8.4.3-full-x86_64-setup.exe download it here for version 8.4.3] of haskell (the full platform doesn't seem to be available for the latest haskell version yet, but you [https://www.haskell.org/platform/windows.html can check here]).
+
<div class="mw-translate-fuzzy">
* [https://atom.io/ Atom Editor] (if you don't like the atom editor for some reason, please check out the [[List of tidal editors|list of alternatives]])
+
* Haskell Platform - '''se recomienda la versión completa''', podés [https://www.haskell.org/platform/download/8.4.3/HaskellPlatform-8.4.3-full-x86_64-setup.exe descargar la versión 8.3.4] de haskell aquí (la plataforma completa parece no estar disponible para la ultima versión de haskell, pero podés [https://www.haskell.org/platform/windows.html encontrarla aquí]).
* [http://supercollider.github.io/download SuperCollider] (pick the latest version)
+
* [https://atom.io/ Editor Atom] (si no te gusta el editor de atom por algún motivo aquí hay una [[List of tidal editors|lista de alternativas]])
 +
* [http://supercollider.github.io/download SuperCollider] (la ultima versión)
 
* [https://git-scm.com/ Git]
 
* [https://git-scm.com/ Git]
 +
</div>
  
 +
<div class="mw-translate-fuzzy">
 
== Recursos Previos Opcionales ==
 
== Recursos Previos Opcionales ==
 +
</div>
  
 
Lo siguiente es opcional, pero recomendado:
 
Lo siguiente es opcional, pero recomendado:
  
* [https://supercollider.github.io/sc3-plugins/ SC3 Plugins] - you may need the SuperCollider sc3-plugins if you want to use any of the synths included in SuperDirt. Most of the examples in the documentation will still work, so you could skip this step and return to it later.
+
* [https://supercollider.github.io/sc3-plugins/ SC3 Plugins] - vas a necesitar los plugins sc3 si querés usar alguno de los sintetizadores incluidos en SuperDirt. La mayoría de los ejemplos en la documentación van a funcionar, así que podes saltear este paso y volver luego.
  
 +
<div class="mw-translate-fuzzy">
 
= Instalar TidalCycles =
 
= Instalar TidalCycles =
 +
</div>
  
 +
<div class="mw-translate-fuzzy">
 
Abrí una terminal (o PowerShell). Luego escribí y ejecutá los siguientes comandos (ignorando cualquier queja alrededor de que cabal tiene un "legado v1 de estilo de uso"):
 
Abrí una terminal (o PowerShell). Luego escribí y ejecutá los siguientes comandos (ignorando cualquier queja alrededor de que cabal tiene un "legado v1 de estilo de uso"):
 +
</div>
  
  cabal update
+
  <div class="mw-translate-fuzzy">
 +
cabal update
 
  cabal install tidal
 
  cabal install tidal
 +
</div>
  
 +
<div class="mw-translate-fuzzy">
 
Si nunca instalaste TidalCycles antes, <code>cabal install tidal</code> puede llegar a tardar bastante tiempo. Al terminar debería decír <code>"Installed tidal-x.x.x"</code> (siendo x.x.x el numero de la última versión) sin ningún error.
 
Si nunca instalaste TidalCycles antes, <code>cabal install tidal</code> puede llegar a tardar bastante tiempo. Al terminar debería decír <code>"Installed tidal-x.x.x"</code> (siendo x.x.x el numero de la última versión) sin ningún error.
 +
</div>
  
 +
If you see an error with the network library, then you need to fix something with your Haskell install. You can [https://forum.toplap.org/t/trouble-launching-tidal-in-atom/678/3 find instructions here].
 +
 +
<div class="mw-translate-fuzzy">
 
= Instalar SuperDirt =
 
= Instalar SuperDirt =
 +
</div>
  
 
En la ventana de edición de SuperCollider copiá y ejecutá la siguiente línea de código:
 
En la ventana de edición de SuperCollider copiá y ejecutá la siguiente línea de código:
  
    Quarks.checkForUpdates(); Quarks.install("SuperDirt", "v1.0")
+
<div class="mw-translate-fuzzy">
 +
Quarks.checkForUpdates(); Quarks.install("SuperDirt", "v1.0")
 +
</div>
  
 +
<div class="mw-translate-fuzzy">
 
Corré el código haciendo clic en él, para asegurarte de que el cursor está en esa línea, después apretá Shift y Enter. Esto va a descargar SuperDirt y vas a poder ver que se completó la descarga cuando puedas leer:
 
Corré el código haciendo clic en él, para asegurarte de que el cursor está en esa línea, después apretá Shift y Enter. Esto va a descargar SuperDirt y vas a poder ver que se completó la descarga cuando puedas leer:
 +
</div>
  
... the class library may have to be recompiled.
+
<div class="mw-translate-fuzzy">
 +
... the class library may have to be recompiled.
 
  -> SuperDirt
 
  -> SuperDirt
 +
</div>
 +
 +
<source lang="plaintext">
 +
Installing SuperDirt
 +
Installing Vowel
 +
Vowel installed
 +
Installing Dirt-Samples
 +
Dirt-Samples installed
 +
SuperDirt installed
 +
compiling class library...
 +
...
 +
(then some blah blah, and finally, something like:)
 +
...
  
Luego de que se completó, vas a tener que reiniciar SuperCollider (o recompilando la librería de clases a través del menú "Languaje").
+
*** Welcome to SuperCollider 3.10.0. *** For help press Ctrl-D.
 +
</source>
  
 +
<div class="mw-translate-fuzzy">
 
= Instalar la extensión de Atom. =
 
= Instalar la extensión de Atom. =
 +
</div>
  
 
Abrí Atom, instalá el plugin para TidalCycles. Podes encontrarlo en el menú edit > settings > install, después escribí “tidalcycles” en la caja de búsqueda. Una vez que se instaló, reiniciá Atom.
 
Abrí Atom, instalá el plugin para TidalCycles. Podes encontrarlo en el menú edit > settings > install, después escribí “tidalcycles” en la caja de búsqueda. Una vez que se instaló, reiniciá Atom.
  
 +
<div class="mw-translate-fuzzy">
 
= Probá tu instalación. =
 
= Probá tu instalación. =
 +
</div>
  
Now you are ready to [[Start_tidalcycles_and_superdirt_for_the_first_time|Start TidalCycles and SuperDirt for the first time]].
+
Ahora podes intentar [[Start_tidalcycles_and_superdirt_for_the_first_time|Start TidalCycles and SuperDirt for the first time]].

Latest revision as of 21:11, 14 December 2019

Easy install

For an easy, automated install experience, see the Windows choco install.

Manual install

If you prefer to install the different parts of a Tidal environment by hand, perhaps because you already have supercollider or haskell installed, then follow the below instructions.

Prerequisitos

Recursos previos necesarios.

Antes de instalar Tidal, asegurate que los siguientes estén instalados.

Recursos Previos Opcionales

Lo siguiente es opcional, pero recomendado:

  • SC3 Plugins - vas a necesitar los plugins sc3 si querés usar alguno de los sintetizadores incluidos en SuperDirt. La mayoría de los ejemplos en la documentación van a funcionar, así que podes saltear este paso y volver luego.

Instalar TidalCycles

Abrí una terminal (o PowerShell). Luego escribí y ejecutá los siguientes comandos (ignorando cualquier queja alrededor de que cabal tiene un "legado v1 de estilo de uso"):

cabal update

cabal install tidal

Si nunca instalaste TidalCycles antes, cabal install tidal puede llegar a tardar bastante tiempo. Al terminar debería decír "Installed tidal-x.x.x" (siendo x.x.x el numero de la última versión) sin ningún error.

If you see an error with the network library, then you need to fix something with your Haskell install. You can find instructions here.

Instalar SuperDirt

En la ventana de edición de SuperCollider copiá y ejecutá la siguiente línea de código:

Quarks.checkForUpdates(); Quarks.install("SuperDirt", "v1.0")

Corré el código haciendo clic en él, para asegurarte de que el cursor está en esa línea, después apretá Shift y Enter. Esto va a descargar SuperDirt y vas a poder ver que se completó la descarga cuando puedas leer:

... the class library may have to be recompiled.

-> SuperDirt
Installing SuperDirt
Installing Vowel
Vowel installed
Installing Dirt-Samples
Dirt-Samples installed
SuperDirt installed
compiling class library...
...
(then some blah blah, and finally, something like:)
...

*** Welcome to SuperCollider 3.10.0. *** For help press Ctrl-D.

Instalar la extensión de Atom.

Abrí Atom, instalá el plugin para TidalCycles. Podes encontrarlo en el menú edit > settings > install, después escribí “tidalcycles” en la caja de búsqueda. Una vez que se instaló, reiniciá Atom.

Probá tu instalación.

Ahora podes intentar Start TidalCycles and SuperDirt for the first time.