Difference between revisions of "Windows installation/de"

From TidalCycles userbase
Jump to: navigation, search
(Created page with "* Haskell-Plattform - Bitte beachten! Es gibt einen Fehler im Windows-Haskell-Installationsprogramm, also installiere [https://www.haskell.org/platform/download/8.4.3/HaskellP...")
(Created page with "Bevor du TidalCycles installierst, stelle sicher, dass du die folgenden Komponenten installiert hast:")
Line 12: Line 12:
 
=== Notwendige Voraussetzungen ===
 
=== Notwendige Voraussetzungen ===
  
Before installing Tidal, make sure the following are installed first:
+
Bevor du TidalCycles installierst, stelle sicher, dass du die folgenden Komponenten installiert hast:
  
 
* Haskell-Plattform - Bitte beachten! Es gibt einen Fehler im Windows-Haskell-Installationsprogramm, also installiere [https://www.haskell.org/platform/download/8.4.3/HaskellPlatform-8.4.3-full-x86_64-setup.exe diese Version] (Haskell 8.4.3 'full' install). So sollte es funktionieren.
 
* Haskell-Plattform - Bitte beachten! Es gibt einen Fehler im Windows-Haskell-Installationsprogramm, also installiere [https://www.haskell.org/platform/download/8.4.3/HaskellPlatform-8.4.3-full-x86_64-setup.exe diese Version] (Haskell 8.4.3 'full' install). So sollte es funktionieren.

Revision as of 16:32, 22 January 2020

Einfache Installation

Für eine einfache und automatisierte Installation vschau Dir Windows choco install an.

Manuelle Installation

Wenn du es vorziehst, die verschiedenen Teile deiner TidalCycles-Umgebung manuell zu installieren - vielleicht weil du bereits SuperCollider oder Haskell installiert hast - dann folge den nachstehenden Anweisungen.

Voraussetzungen

Notwendige Voraussetzungen

Bevor du TidalCycles installierst, stelle sicher, dass du die folgenden Komponenten installiert hast:

  • Haskell-Plattform - Bitte beachten! Es gibt einen Fehler im Windows-Haskell-Installationsprogramm, also installiere diese Version (Haskell 8.4.3 'full' install). So sollte es funktionieren.
  • Atom-Editor (wenn du den Atom-Editor aus irgendeinem Grund nicht magst, schau Dir die Liste der Alternativen an)
  • SuperCollider (installiere die neueste Version)
  • Git

Optional Prerequisites

The following is optional, but recommended:

  • SC3 Plugins - you may need the SuperCollider sc3-plugins if you want to use any of the synths included in SuperDirt. Most of the examples in the documentation will still work, so you could skip this step and return to it later.

Install TidalCycles

Open a Command Prompt (or PowerShell), then type and run these two commands:

 cabal update
 cabal install tidal

If you've never installed TidalCycles before, then the cabal install tidal step may take some time.

If you see an error with the network library, then you need to fix something with your Haskell install. You can find instructions here.

Install SuperDirt

Start SuperCollider, and in the editor window paste in the following line of code:

Quarks.checkForUpdates({Quarks.install("SuperDirt", "v1.1.1"); thisProcess.recompile()})

Run the code by clicking on it, to make sure the cursor is on this line, then hold down Shift and press Enter.

It'll take a while to install. You'll see something like the following:

Installing SuperDirt
Installing Vowel
Vowel installed
Installing Dirt-Samples
Dirt-Samples installed
SuperDirt installed
compiling class library...
...
(then some blah blah, and finally, something like:)
...

*** Welcome to SuperCollider 3.10.0. *** For help press Ctrl-D.

Install Atom Extension

Start Atom, and install the TidalCycles plugin. You can find it via the menus under edit > settings > install, then typing “tidalcycles” into the search box. Once that’s installed, restart atom.

Test Your Installation

Now you are ready to Start TidalCycles and SuperDirt for the first time.