Linux installation

From TidalCycles userbase
Revision as of 16:09, 14 November 2018 by Kindohm (talk | contribs) (Created page with "== Prerequisites == The following are required: * [https://www.haskell.org/platform/ Haskell Platform] - the Full platform is recommended. Advanced users may try using the C...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Prerequisites

The following are required:

Hopefully your Linux distribution makes these easily available to you via a package manager. For example, if you are using recent version of Ubuntu or similar, you can install supercollider and haskell with the following command in a terminal window:

sudo apt-get install supercollider sc3-plugins cabal-install git

Make sure the supercollider version is 3.7 or later. If it isn’t available in your Linux distribution, then you may have to compile a newer version yourself, or upgrade your distribution.

The following are optional:

  • SC3 Plugins - you may need the SuperCollider sc3-plugins if you want to use any of the synths included in SuperDirt. Most of the examples in the documentation will still work, so you could skip this step and return to it later.